High CPU usage on Win7

4 replies [Last post]
diego_o
User offline. Last seen 3 years 41 weeks ago. Offline
Joined: 11/14/2010
Posts: 3

Hi, first I have to say that this is the best worms clone I've seen so far; it really captures the essence of the original game. However, when I try to play it on my laptop, the game runs kinda slow (10-20 fps low detail, 30 on high) and it uses up a full core. I searched on the forum, but all poor performance issues I've found so far are related to bad drivers lacking OpenGL support, but I can play other games based on OpenGL perfectly and I'm using a Nvidia card with proper drivers!

Well, these are the specs:

OS: Windows 7 Home Premium 64-bits
CPU: Pentium(R) Dual-COre CPU T4400 @ 2.20 Ghz
RAM: 4.00 GB
Video Card: NVIDIA GeForce G210M with driver 187.66

Also this is what debug0.txt says about rendering:

0: OpenGL-- Renderer: GeForce G210M/PCI/SSE2
0: |----- Vendor: nvidia corporation
0: |----- Version: 3.1 NVIDIA 187.66
0: \----- GL_MAX_TEXTURE_SIZE: 8192

Please help!

Inu
Inu's picture
User offline. Last seen 6 hours 29 min ago. Offline
Joined: 08/26/2009
Posts: 240

Can't help you there, you need to wait for a dev, just wanted to clear that Hedgewars is NOT a w*r*s "clone" IN AWAY WAY!
The games just share the same genera, Artillery, like Call of Duty and Halo are First Person Shooters.
The code was written from scratch, the physics don't work the same way, and all the most funny weapons are "Hedgewars exclusive".

There is definitely something wrong with your drivers, even an Atom with it's integrated GPU runs Hedgewars flawlessly.

Also, which version of Hedgewars are you running?

diego_o
User offline. Last seen 3 years 41 weeks ago. Offline
Joined: 11/14/2010
Posts: 3

Sorry I just screwed it up, I guess D:
Today I downloaded the lastest, 0.9.13

Inu
Inu's picture
User offline. Last seen 6 hours 29 min ago. Offline
Joined: 08/26/2009
Posts: 240

A new version was released a few hours ago.
Hedgewars 0.9.14, give it a try! Smile

diego_o
User offline. Last seen 3 years 41 weeks ago. Offline
Joined: 11/14/2010
Posts: 3

Solved, updated the drivers and everything now is working fine. I shouldn't have posted without trying that :$

Copyright © 2004-2014 Hedgewars Project. All rights reserved.