Windows 7, 64Bit. Game Won't Play.

9 replies [Last post]
HEO Girl
User offline. Last seen 3 years 21 weeks ago. Offline
Joined: 05/20/2011
Posts: 5

I am running 64bit windows 7.

I have installed the game successfully and can open it and make my team but when I get into a game and it starts it doesn't open a new window. Instead it stays on a window with pictures of tree's and stars and doesn't go any further then that.

I deleted everything and redownloaded then reinstalled with the same results.

Is there a 64bit version I can download? or is the one on this website for windows for both?

Help.

HEO Girl
User offline. Last seen 3 years 21 weeks ago. Offline
Joined: 05/20/2011
Posts: 5

I want to also say that I have no other firewalls but the regular old windows firewall and my anti virus is AVG: Free.

HEO Girl
User offline. Last seen 3 years 21 weeks ago. Offline
Joined: 05/20/2011
Posts: 5

I want to also say that I have the ATI Radeon HD 5870 graphics card. I did a search on google and believe it doesn't have any issue supporting openGL

nemo
nemo's picture
User offline. Last seen 2 days 15 hours ago. Offline
Joined: 01/28/2009
Posts: 1199

Please post My Documents/Hedgewars/Logs/game0.log

Also, are you using Comodo Firewall?

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

HEO Girl
User offline. Last seen 3 years 21 weeks ago. Offline
Joined: 05/20/2011
Posts: 5

No I do not have any of that fancy stuff. Just what windows came with for their firewall and AVG: Free for antivirus.

0: [Con] Hedgewars 0.9.15 engine (network protocol: 37)
0: Prefix: "C:/Program Files (x86)/Hedgewars 0.9.15/share/hedgewars/Data"
0: 0: C:\Program Files (x86)\Hedgewars 0.9.15\bin\hwengine.exe
0: 1: C:/Users/DieselJunki/Documents/Hedgewars
0: 2: 1600
0: 3: 900
0: 4: 32
0: 5: 53378
0: 6: 0
0: 7: 1
0: 8: 1
0: 9: 128
0: 10: 8
0: 11: C:/Program Files (x86)/Hedgewars 0.9.15/share/hedgewars/Data
0: 12: 0
0: 13: 0
0: 14: SEVPIEdpcmw=
0: 15: 0
0: 16: en.txt
0: [Con] Init SDL...
0: [Con] ok
0: [Con] Init SDL_ttf...
0: [Con] ok
0: [Cmd] /fullscr (1)
0: Prepare to change video parameters...
0: [Con] Loading C:/Program Files (x86)/Hedgewars 0.9.15/share/hedgewars/Data/Graphics/hwengine.png [flags: 8]
0: [Con] ok (32x32)

nemo
nemo's picture
User offline. Last seen 2 days 15 hours ago. Offline
Joined: 01/28/2009
Posts: 1199

Ok, it is definitely crashing on setup of opengl.

That's not terribly unusual I guess, since Microsoft has been trying to kill off OpenGL in windows, and gotten more aggressive in Windows 7.

Both Firefox and Chrome are forced to use ANGLE to implement GLES2 support in their browsers for Windows, which is not ideal.

Hedgewars might have to do the same thing eventually for its windows users.

Please check to see if there is a driver from your manufacturer of your video card that might have OpenGL support, and try installing that.

If you don't have much luck finding one, you can try posting your graphics card details here, and I can poke around for one.

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

HEO Girl
User offline. Last seen 3 years 21 weeks ago. Offline
Joined: 05/20/2011
Posts: 5

I have checked the website for any updates and didn't see anything unless perhaps I missed something. I just took my laptop in a few months ago and had it re-pasted and with that I got the most recent updates to my drivers.

I have a ATI Radeon HD 5870.
Driver Version: 8.683.0.0

nemo
nemo's picture
User offline. Last seen 2 days 15 hours ago. Offline
Joined: 01/28/2009
Posts: 1199

HEO Girl wrote:

I have checked the website for any updates and didn't see anything unless perhaps I missed something. I just took my laptop in a few months ago and had it re-pasted and with that I got the most recent updates to my drivers.

I have a ATI Radeon HD 5870.
Driver Version: 8.683.0.0

http://sites.amd.com/us/game/downloads/Pages/radeon_win7-32.aspx (If your windows is 32 bit)
http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx (If it is 64 bit)

http://support.amd.com/us/kbarticles/Pages/Catalyst-OpenGL-preview-driver.aspx (looks like you can also try this one)

taking your laptop in does not guarantee latest drivers, esp for windows Smile

Windows is not going to casually upgrade graphics card drivers, and is unlikely most support places would either, unless you explicitly asked to make sure it is the latest.

That being said, that version does sound fairly up to date - I just don't know if it includes OpenGL.

The one that explicitly says so (Catalyst OpenGL preview) sounds like a good bet.

If you go to about:support in Firefox 4 - does it say it is using the ATI driver for WebGL, or ANGLE?

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

rockachu2
rockachu2's picture
User offline. Last seen 2 years 46 weeks ago. Offline
Joined: 07/08/2010
Posts: 85

I have a 5870 too. Hedgewars works fine. Check the taskbar and make sure the window isn't hidden by some quirk. I am also using win 7 x64. BUT I have the latest drivers.

My favorite sport: nerd sniping.

archerkir
User offline. Last seen 1 year 50 weeks ago. Offline
Joined: 12/25/2010
Posts: 17

Windows 7 x64 / Windows 7 x64 SP1, Radeon Mobile HD 3470 - works perfect!

Copyright © 2004-2014 Hedgewars Project. All rights reserved. [ contact ]