in game...

8 replies [Last post]
pr
User offline. Last seen 11 years 42 weeks ago. Offline
Joined: 2008-09-13
Posts: 1

Запустил сейчас игру, при создании новой игры пишет в окне "in game..." и ничего не происходит.
ОС Vista, NVIDIA GF7400

unC0Rr
unC0Rr's picture
User offline. Last seen 2 weeks 3 days ago. Offline
Joined: 2006-11-27
Posts: 574

Покажи, что у тебя в debug0.txt

OverLine
User offline. Last seen 10 years 5 weeks ago. Offline
Joined: 2010-05-23
Posts: 2

Та же самая проблема, OC Ubuntu 10.4

Содержимое debug0.txt
0: Console write: Hedgewars 0.9.13 engine (network protocol: 31)
0: Prefix: "/usr/share/games/hedgewars/Data"
0: 0: /usr/lib/hedgewars/bin/hwengine
0: 1: /home/overline/.hedgewars
0: 2: 1280
0: 3: 1024
0: 4: 32
0: 5: 60087
0: 6: 1
0: 7: 1
0: 8: 0
0: 9: 1
0: 10: ru.txt
0: 11: 128
0: 12: 8
0: 13: /usr/share/games/hedgewars/Data
0: 14: 0
0: 15: 0
0: 16: b3ZlcmxpbmU=
0: 17: 1
0: 18: 1
0: Console write: Init SDL...
0: Console write: ok
0: Console write: Init SDL_ttf...
0: Console write: ok
0: ParseCommand "fullscr 1"
0: Prepare to change video parameters...
0: Console write: Init SDL_image...
0: Console write: ok
0: Console write: Loading /usr/share/games/hedgewars/Data/Graphics/hwengine [flags: 8]...
0: Console write: (32,32)
0: Console write: ok

OverLine
User offline. Last seen 10 years 5 weeks ago. Offline
Joined: 2010-05-23
Posts: 2

Блин, ну что нибудь можете сказать? Очень хочется поиграть

blitzwing
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2010-12-30
Posts: 2

Тоже "in game.." и всё. Система Debian Sid. Hedgewars 0.9.15

blitzwing
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2010-12-30
Posts: 2

P.S. Вот game0.log
~/.hedgewars/Logs% cat game0.log
0: [Con] Hedgewars 0.9.15 engine (network protocol: 37)
0: Prefix: "/usr/share/games/hedgewars/Data"
0: 0: /usr/lib/hedgewars/bin/hwengine
0: 1: /home/blitzwing/.hedgewars
0: 2: 640
0: 3: 480
0: 4: 32
0: 5: 60657
0: 6: 0
0: 7: 1
0: 8: 1
0: 9: 128
0: 10: 8
0: 11: /usr/share/games/hedgewars/Data
0: 12: 0
0: 13: 0
0: 14: YmxpdHp3aW5n
0: 15: 3070
0: 16: ru.txt
0: [Con] Init SDL...
0: [Con] ok
0: [Con] Init SDL_ttf...
0: [Con] ok
0: [Cmd] /fullscr (1)
0: Prepare to change video parameters...
0: [Con] Init SDL_image...
0: [Con] ok
0: [Con] Loading /usr/share/games/hedgewars/Data/Graphics/hwengine.png [flags: 8]
0: [Con] ok (32x32)
0: Setting up OpenGL...
0: SDL video driver: x11
0: OpenGL-- Renderer: Mesa DRI UniChrome 20060710 x86/MMX/SSE2
0: |----- Vendor: VIA Technology
0: |----- Version: 1.2 Mesa 7.7.1
0: \----- GL_MAX_TEXTURE_SIZE: 512
0: [Con] Loading progress sprite:
0: [Con] Loading /usr/share/games/hedgewars/Data/Graphics/Progress.png [flags: 6]
0: [Con] failed due to size
0: [Cmd] /fatal (117)

unC0Rr
unC0Rr's picture
User offline. Last seen 2 weeks 3 days ago. Offline
Joined: 2006-11-27
Posts: 574

В последнем случае видеокарта не держит большой размер текстур. Можно попробовать минимальные настройки графики

cirno
User offline. Last seen 8 years 42 weeks ago. Offline
Joined: 2011-09-18
Posts: 1

пришлось регистрироваться.
Была такая же проблема и поэтому рекомендую тем у кого "in game" выйти из hedgewars и запустить в консоли hwengine.
У меня он выругался на отсутствие sdl_net, после его установки всё заработало.

PS: Почему-то у меня не создаётся файл лога в 15 версии, ну мне это не важно.

faiwer
faiwer's picture
User offline. Last seen 4 years 51 weeks ago. Offline
Joined: 2011-07-16
Posts: 3

Quote:
0: [Con] Hedgewars 0.9.16 engine (network protocol: 39)
0: Prefix: "/usr/share/games/hedgewars/Data"
0: UserPrefix: "/home/faiwer/.hedgewars"
0: 0: /usr/lib/hedgewars/bin/hwengine
0: 1: /home/faiwer/.hedgewars
0: 2: 1280
0: 3: 1024
0: 4: 32
0: 5: 43602
0: 6: 1
0: 7: 1
0: 8: 1
0: 9: 19
0: 10: 8
0: 11: /usr/share/games/hedgewars/Data
0: 12: 0
0: 13: 0
0: 14: ZmFpd2Vy
0: 15: 0
0: 16: 0
0: 17: ru.txt
0: [Con] Init SDL...
0: [Con] ok
0: [Con] Init SDL_ttf...
0: [Con] ok
0: [Cmd] /fullscr (1)
0: Preparing to change video parameters...
0: [Con] Init SDL_image...
0: [Con] ok
0: [Con] Loading /home/faiwer/.hedgewars/Data/Graphics/hwengine.png [flags: 8]
0: [Con] failed
0: [Con] Loading /usr/share/games/hedgewars/Data/Graphics/hwengine.png [flags: 8]
0: [Con] ok (32x32)

Так же фигня. Пробовал переставить - ноль внимания. Есть идеи?

Ubuntu 11.04 32bit, Win7 32bit

Copyright © 2004-2017 Hedgewars Project. All rights reserved. [ contact ]