Error when building from source on Windows 10 64-bit.

No replies
Shadow_The_Worm
Shadow_The_Worm's picture
User offline. Last seen 1 week 1 day ago. Offline
Joined: 2018-02-10
Posts: 50

Hello. So, I decided to build a newer version of Hedgewars on my PC with Windows 10 64-bit. I did everything as the instructions said, however right now I have the following problem:

Quote:
Running cmake...
CMake Warning:
Ignoring empty string ("") provided on the command line.

CMake Warning (dev) at CMakeLists.txt:1 (project):
cmake_minimum_required() should be called prior to this top-level project()
call. Please see the cmake-commands(7) manual for usage documentation of
both commands.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Error at C:/Program Files/CMake/share/cmake-3.26/Modules/CMakeDetermineSystem.cmake:154 (message):
Could not find toolchain file: \scripts\buildsystems\vcpkg.cmake
Call Stack (most recent call first):
CMakeLists.txt:1 (project)

CMake Error: CMake was unable to find a build program corresponding to "NMake Makefiles". CMAKE_MAKE_PROGRAM is not set. You probably need to select a different build tool.
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
Для продолжения нажмите любую клавишу . . .

Any way I can fix this? And no, don't tell me to move to Linux, I want a Windows build and I'm not going to move to a system I do not want to use. Yours sincerely, Shadow The Worm.

User login

Copyright © 2004-2024 Hedgewars Project. All rights reserved. [ contact ]