No teams showed online

5 replies [Last post]
volvo480
User offline. Last seen 29 weeks 1 day ago. Offline
Joined: 2019-12-13
Posts: 2

Hi HedgewarsCommunity,

when i try to play online I can join a room without problems but can't play because there is no team to choose in the player selection. It makes no difference if i have a account or make my own team - There is no team in the selection.

I play on Win10 and can play offline without problems. I tried to deactivate the firewall and my Anti Virus programm (BitDefender) but nothing worked. I also reinstalled the game two times.

Do you have an idea what the problem could be?

I am happy about every tipp Smile

MacDev27
User offline. Last seen 33 weeks 2 days ago. Offline
Joined: 2011-10-18
Posts: 1

Interesting, I've got exactly the same problem with a friend who'd like to play with me Sad Smiley There are no teams to select from when he joins the room. Haven't found a fix yet either...

nemo
nemo's picture
User offline. Last seen 7 hours 14 min ago. Offline
Joined: 2009-01-28
Posts: 1807

What version are you guys playing?

Also. When you go to config (wrench lower right main screen menu) - do you actually have teams?

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

volvo480
User offline. Last seen 29 weeks 1 day ago. Offline
Joined: 2019-12-13
Posts: 2

We use the Version 1.0.0 and yes there are teams shown in the config. But in a online room ehere is no team to choose.

But we found the problem and how to fix it:

The problem is, that there is no team in the user datas ("Documents\Hedgewars\Teams"). We just sent him one team txt file from us and now he can play.

Don't know why the teams, which you can see in the congi are thjere missing.
Maybe this helps some one else as well.

nemo
nemo's picture
User offline. Last seen 7 hours 14 min ago. Offline
Joined: 2009-01-28
Posts: 1807

So if you'd gone into config settings you would have seen that Smile.

(The wrench off the main menu).

My guess is we only create a default set of teams for a new config folder.

It could be the computer you are on has an older hedgewars config folder. It might even have old style team files.

Existing hedgewars configs don't get new teams autocreated.

Little hard to figure out at this point, but any info you could offer would be helpful.

Deleting the hedgewars config folder entirely would allow the teams to be recreated.

You could possibly look in the profile to see if you see any clues of old config from versions past.

I guess I can try replicating this by running, say, 0.9.17, exiting, then trying to run 1.0.0

Will try and remember to do that later tonight.

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

Wuzzy
Wuzzy's picture
User offline. Last seen 11 hours 2 min ago. Offline
Joined: 2012-06-20
Posts: 1190

Ah, good catch, nemo. Right, it could be due to a failed conversion from an old version (pre-1.0.0). This sounds very realistic.

Hi, I am a Hedgewars developer. Smile I accept personal donations in bitcoin. Heart 17fsUywHxeMHKG41UFfu34F1rAxZcrVoqH

Copyright © 2004-2017 Hedgewars Project. All rights reserved. [ contact ]